cpp using ubuntu gives error

Discussion in 'Programmer's Corner' started by ep.hobbyiest, Jan 31, 2015.

  1. ep.hobbyiest

    Thread Starter Member

    Aug 26, 2014
    91
    0
    hello i am using ubuntu. i tried C on ubuntu but i am facing some problem with cpp.
    i done hello.cpp file and in terminal entered.
    g++ hello.cpp
    it shows that you have not install g++.
    Code (Text):
    1.  php5-gd : Depends: phpapi-20121212+lfs
    2.            Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but it is not going to be installed
    3. php5-gmp : Depends: phpapi-20121212+lfs
    4.             Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but it is not going to be installed
    5. php5-pgsql : Depends: libpq5 (>= 9.0~) but it is not installable
    6.               Depends: phpapi-20121212+lfs
    7.               Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but it is not going to be installed
    8. pidgin : Depends: libgtkspell0 (>= 2.0.10) but it is not installable
    9.           Recommends: pidgin-libnotify but it is not installable
    10. pidgin-dev : Depends: libpurple-dev but it is not going to be installed
    11.               Depends: libgtk2.0-dev but it is not installable
    12. plasma-dataengines-workspace : Depends: kdepim-runtime but it is not installable
    13.                                 Depends: libakonadi-calendar4 (>= 4:4.10.80) but it is not going to be installed
    14.                                 Depends: libakonadi-kde4 (>= 4:4.11.6) but it is not going to be installed
    15.                                 Depends: libakonadi-kmime4 (>= 4:4.11.6) but it is not going to be installed
    16.                                 Depends: libgps20 (>= 3.3) but it is not installable
    17.                                 Depends: libkabc4 (>= 4:4.11.6) but it is not going to be installed
    18.                                 Depends: libkactivities6 (>= 4:4.8.80) but it is not going to be installed
    19.                                 Depends: libkcalcore4 (>= 4:4.5.86) but it is not going to be installed
    20.                                 Depends: libkcalutils4 (>= 4:4.5.86) but it is not going to be installed
    21.                                 Depends: libkdecore5 (>= 4:4.5.86) but it is not going to be installed
    22.                                 Depends: libkdeui5 (>= 4:4.3.4) but it is not going to be installed
    23.                                 Depends: libkfile4 (>= 4:4.3.4) but it is not going to be installed
    24.                                 Depends: libkholidays4 (>= 4:4.11.6) but it is not going to be installed
    25.                                 Depends: libkidletime4 (>= 4:4.4.95) but it is not going to be installed
    26.                                 Depends: libkio5 (>= 4:4.3.4) but it is not going to be installed
    27.                                 Depends: libkmime4 (>= 4:4.11.6) but it is not going to be installed
    28.                                 Depends: libkrosscore4 (>= 4:4.3.4) but it is not going to be installed
    29.                                 Depends: libkworkspace4abi2 (= 4:4.11.11-0ubuntu0.2) but it is not going to be installed
    30.                                 Depends: libnepomukcore4abi1 (>= 4:4.9.0) but it is not going to be installed
    31.                                 Depends: libplasma3 (>= 4:4.7.4) but it is not going to be installed
    32.                                 Depends: libsyndication4 (>= 4:4.11.6) but it is not going to be installed
    33.                                 Depends: libweather-ion6 (= 4:4.11.11-0ubuntu0.2) but it is not going to be installed
    34. plasma-scriptengine-javascript : Depends: libkdecore5 (>= 4:4.4.0) but it is not going to be installed
    35.                                   Depends: libkdeui5 (>= 4:4.3.4) but it is not going to be installed
    36.                                   Depends: libkio5 (>= 4:4.3.4) but it is not going to be installed
    37.                                   Depends: libplasma3 (>= 4:4.7.0) but it is not going to be installed
    38. plasma-scriptengine-python : Depends: python-kde4 (>= 4:4.6.80) but it is not installable
    39. plasma-scriptengine-ruby : Depends: ruby-plasma but it is not installable
    40. plasma-scriptengine-webkit : Depends: libkdecore5 (>= 4:4.4.95) but it is not going to be installed
    41.                               Depends: libkdeui5 (>= 4:4.3.4) but it is not going to be installed
    42.                               Depends: libkio5 (>= 4:4.3.4) but it is not going to be installed
    43.                               Depends: libplasma3 (>= 4:4.4.4-2~) but it is not going to be installed
    44. plasma-widgets-workspace : Depends: libkdecore5 (>= 4:4.5.86) but it is not going to be installed
    45.                             Depends: libkdeui5 (>= 4:4.4.95) but it is not going to be installed
    46.                             Depends: libkdewebkit5 (>= 4:4.4.0) but it is not going to be installed
    47.                             Depends: libkio5 (>= 4:4.4.0) but it is not going to be installed
    48.                             Depends: libkunitconversion4 (>= 4:4.4.0) but it is not going to be installed
    49.                             Depends: libplasma3 (>= 4:4.7.0) but it is not going to be installed
    50.                             Depends: libplasmaclock4abi4 (= 4:4.11.11-0ubuntu0.2) but it is not going to be installed
    51.                             Depends: akonadi-server but it is not installable
    52.                             Depends: kdepim-runtime but it is not installable
    53. python-django-doc : Depends: libjs-sphinxdoc (>= 1.0) but it is not installable
    54. python-django-horizon : Depends: python-ceilometerclient but it is not installable
    55.                          Depends: python-cinderclient but it is not installable
    56.                          Depends: python-cloudfiles but it is not installable
    57.                          Depends: python-compressor (>= 1.2) but it is not installable
    58.                          Depends: python-glanceclient but it is not installable
    59.                          Depends: python-heatclient but it is not installable
    60.                          Depends: python-keystoneclient but it is not installable
    61.                          Depends: python-memcache but it is not installable
    62.                          Depends: python-netaddr but it is not installable
    63.                          Depends: python-neutronclient but it is not installable
    64.                          Depends: python-novaclient but it is not installable
    65.                          Depends: python-openstack-auth (>= 1.1.1) but it is not installable
    66.                          Depends: python-swiftclient but it is not installable
    67.                          Depends: python-troveclient but it is not installable
    68.                          Depends: python-tz but it is not installable
    69.                          Recommends: memcached but it is not installable
    70. python-django-maas : Depends: python-amqp but it is not installable
    71.                       Depends: python-celery but it is not installable
    72.                       Depends: python-convoy but it is not installable
    73.                       Depends: python-crochet but it is not installable
    74.                       Depends: python-curtin but it is not installable
    75.                       Depends: python-maas-client (= 1.5.4+bzr2294-0ubuntu1.2) but it is not going to be installed
    76.                       Depends: python-netaddr but it is not installable
    77.                       Depends: python-oops but it is not installable
    78.                       Depends: python-oops-amqp but it is not installable
    79.                       Depends: python-oops-datedir-repo but it is not installable
    80.                       Depends: python-oops-twisted but it is not installable
    81.                       Depends: python-oops-wsgi but it is not installable
    82.                       Depends: python-psycopg2 but it is not installable
    83.                       Depends: python-sphinx but it is not installable
    84.                       Depends: python-tempita but it is not installable
    85.                       Depends: python-twisted but it is not installable
    86.                       Depends: python-txamqp but it is not installable
    87.                       Depends: python-txlongpoll but it is not installable
    88. python-glance : Depends: python-anyjson (>= 0.3.3) but it is not installable
    89.                  Depends: python-boto (>= 2.4.0) but it is not installable
    90.                  Depends: python-cinderclient (>= 1:1.0.4) but it is not installable
    91.                  Depends: python-eventlet (>= 0.13.0) but it is not installable
    92.                  Depends: python-greenlet (>= 0.3.2) but it is not installable
    93.                  Depends: python-iso8601 but it is not installable
    94.                  Depends: python-jsonschema (>= 1.3.0) but it is not installable
    95.                  Depends: python-keystoneclient (>= 1:0.3.0) but it is not installable
    96.                  Depends: python-kombu (>= 2.4.8) but it is not installable
    97.                  Depends: python-migrate but it is not installable
    98.                  Depends: python-oslo.config (>= 1:1.2.0a3) but it is not installable
    99.                  Depends: python-passlib but it is not installable
    100.                  Depends: python-paste but it is not installable
    101.                  Depends: python-pastedeploy but it is not installable
    102.                  Depends: python-routes but it is not installable
    103.                  Depends: python-sqlalchemy-ext but it is not installable or
    104.                           python-sqlalchemy (>= 0.8.2) but it is not installable
    105.                  Depends: python-swiftclient (>= 1:1.2) but it is not installable
    106.                  Depends: python-webob (>= 1.2.3) but it is not installable
    107.                  Depends: python-pbr but it is not installable
    108.                  Depends: python-sqlalchemy (>= 0.8~) but it is not installable
    109.                  Depends: python-sqlalchemy (< 0.9) but it is not installable
    110.                  Depends: python-stevedore but it is not installable
    111.                  Depends: python-oslo.vmware but it is not installable
    112.                  Depends: python-oslo.messaging but it is not installable
    113. python-glance-doc : Depends: libjs-jquery but it is not installable
    114. python-libtorrent-dbg : Depends: libboost-python1.54.0 but it is not installable
    115.                          Depends: python-dbg (>= 2.7) but it is not installable
    116.                          Depends: python-dbg (< 2.8) but it is not installable
    117.                          Depends: python-libtorrent (= 0.16.13-1ubuntu2.1) but it is not going to be installed
    118. python-libxml2-dbg : Depends: python-dbg but it is not installable
    119.                       Depends: libpython2.7-dbg (>= 2.7) but it is not installable
    120. python-lxml-dbg : Depends: python-dbg but it is not installable
    121. python-maas-provisioningserver : Depends: python-amqp but it is not installable
    122.                                   Depends: python-celery but it is not installable
    123.                                   Depends: python-crochet but it is not installable
    124.                                   Depends: python-distro-info but it is not installable
    125.                                   Depends: python-formencode but it is not installable
    126.                                   Depends: python-jsonschema but it is not installable
    127.                                   Depends: python-maas-client but it is not going to be installed
    128.                                   Depends: python-netifaces but it is not installable
    129.                                   Depends: python-oops but it is not installable
    130.                                   Depends: python-oops-amqp but it is not installable
    131.                                   Depends: python-oops-datedir-repo but it is not installable
    132.                                   Depends: python-oops-twisted but it is not installable
    133.                                   Depends: python-paramiko but it is not installable
    134.                                   Depends: python-pyparsing but it is not installable
    135.                                   Depends: python-seamicroclient but it is not installable
    136.                                   Depends: python-simplestreams but it is not installable
    137.                                   Depends: python-tempita but it is not installable
    138.                                   Depends: python-txamqp but it is not installable
    139.                                   Depends: python-txtftp but it is not installable
    140. python-pycuda-dbg : Depends: python-pycuda (= 2013.1.1+git20140310-1ubuntu1) but it is not going to be installed
    141.                      Depends: python-dbg (>= 2.7) but it is not installable
    142.                      Depends: libboost-python1.54.0 but it is not installable
    143.                      Depends: libboost-thread1.54.0 but it is not installable
    144.                      Depends: python-numpy (>= 1:1.8.0) but it is not installable
    145.                      Depends: python-numpy-abi9 but it is not installable
    146.                      Depends: python-dbg (< 2.8) but it is not installable
    147. python-pyopencl-dbg : Depends: python-pyopencl (= 2013.2-1build1) but it is not going to be installed
    148.                        Depends: python-dbg (>= 2.7) but it is not installable
    149.                        Depends: libboost-python1.54.0 but it is not installable
    150.                        Depends: libopencl-1.1-1 but it is not installable
    151.                        Depends: libopencl-1.2-1 but it is not installable
    152.                        Depends: ocl-icd-libopencl1 but it is not installable
    153.                        Depends: python-numpy (>= 1:1.7-0~b1) but it is not installable
    154.                        Depends: python-numpy-abi9 but it is not installable
    155.                        Depends: python-dbg (< 2.8) but it is not installable
    156. python-reportbug : Depends: python-support (>= 0.90.0) but it is not installable
    157.                     Depends: python-debianbts but it is not installable
    158. python-subversion-dbg : Depends: python-subversion (= 1.8.8-1ubuntu3.1) but it is not going to be installed
    159.                          Depends: python-dbg (>= 2.7) but it is not installable
    160.                          Depends: libapr1 (>= 1.2.7) but it is not installable
    161.                          Depends: libsvn1 (>= 1.8) but it is not going to be installed
    162.                          Depends: python-dbg (< 2.8) but it is not installable
    163. python-yaml-dbg : Depends: python-dbg but it is not installable
    164. python3-libtorrent-dbg : Depends: libboost-python1.54.0 but it is not installable
    165.                           Depends: python3-dbg (>= 3.4~) but it is not installable
    166.                           Depends: python3-dbg (< 3.5) but it is not installable
    167.                           Depends: python-libtorrent (= 0.16.13-1ubuntu2.1) but it is not going to be installed
    168. python3-lxml-dbg : Depends: python3-dbg but it is not installable
    169. python3-pycuda-dbg : Depends: python3-pycuda (= 2013.1.1+git20140310-1ubuntu1) but it is not going to be installed
    170.                       Depends: python3-dbg (< 3.5) but it is not installable
    171.                       Depends: libboost-python1.54.0 but it is not installable
    172.                       Depends: libboost-thread1.54.0 but it is not installable
    173.                       Depends: python3-numpy (>= 1:1.8.0) but it is not installable
    174.                       Depends: python3-numpy-abi9 but it is not installable
    175.                       Depends: python3-dbg (>= 3.4~) but it is not installable
    176. python3-pyopencl-dbg : Depends: python3-pyopencl (= 2013.2-1build1) but it is not going to be installed
    177.                         Depends: python3-dbg (>= 3.3) but it is not installable
    178.                         Depends: libboost-python1.54.0 but it is not installable
    179.                         Depends: libopencl-1.1-1 but it is not installable
    180.                         Depends: libopencl-1.2-1 but it is not installable
    181.                         Depends: ocl-icd-libopencl1 but it is not installable
    182.                         Depends: python3-numpy (>= 1:1.7-0~b1) but it is not installable
    183.                         Depends: python3-numpy-abi9 but it is not installable
    184.                         Depends: python3-dbg (< 3.5) but it is not installable
    185. python3-yaml-dbg : Depends: python3-dbg but it is not installable
    186. quassel-dbg : Depends: quassel (= 0.10.0-0ubuntu2.1) but it is not going to be installed or
    187.                         quassel-client (= 0.10.0-0ubuntu2.1) but it is not going to be installed or
    188.                         quassel-core (= 0.10.0-0ubuntu2.1) but it is not going to be installed
    189. redeclipse-dbg : Depends: redeclipse (= 1.4-5) but it is not going to be installed
    190. redeclipse-server-dbg : Depends: redeclipse-server (= 1.4-5) but it is not going to be installed
    191. registry-tools : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2.14.04.3) but 2:4.1.6+dfsg-1ubuntu2.14.04.2 is to be installed
    192. ripoff-mp3-plugin : Depends: libmp3lame0 but it is not installable
    193.                      Depends: libripoff0 (>= 0.8.3) but it is not installable
    194.                      Recommends: ripoff but it is not installable
    195. rsyslog-mysql : Depends: dbconfig-common but it is not installable
    196.                  Recommends: mysql-client
    197. rsyslog-pgsql : Depends: libpq5 but it is not installable
    198.                  Depends: dbconfig-common but it is not installable
    199.                  Recommends: postgresql-client but it is not installable
    200. rsyslog-relp : Depends: librelp0 (>= 1.0.3) but it is not installable
    201. ruby-pgplot : Depends: ruby-narray but it is not installable
    202. ruby1.9.1 : Depends: ruby (>= 1:1.9.3.1) but it is not installable
    203. samba-dbg : Depends: samba (= 2:4.1.6+dfsg-1ubuntu2.14.04.4) but it is not going to be installed
    204. sandboxgamemaker : Depends: libenet2a (>= 1.3.7+ds) but it is not installable
    205.                     Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
    206.                     Depends: libsdl-mixer1.2 but it is not installable
    207.                     Depends: libsdl1.2debian (>= 1.2.11) but it is not installable
    208.                     Depends: libwxbase2.8-0 (>= 2.8.12.1) but it is not installable
    209.                     Depends: libwxgtk2.8-0 (>= 2.8.12.1) but it is not installable
    210.                     Recommends: libsmpeg0 but it is not installable
    211.                     Recommends: mikmod but it is not installable
    212.                     Recommends: timidity but it is not installable
    213. sapgui-package : Depends: cdbs but it is not installable
    214.                   Depends: fakeroot but it is not installable
    215.                   Depends: openjdk-6-jre but it is not going to be installed or
    216.                            java5-runtime
    217.                   Depends: python-support (>= 0.90.0) but it is not installable
    218. sauerbraten-dbg : Depends: sauerbraten (= 0.0.20130203.dfsg-1) but it is not going to be installed
    219. sdic-gene95 : Depends: nkf but it is not installable
    220.                Recommends: sdic but it is not going to be installed
    221.                Recommends: sufary but it is not installable
    222. sqldeveloper-package : Depends: devscripts but it is not installable
    223.                         Depends: fakeroot but it is not installable
    224.                         Depends: tofrodos but it is not installable
    225.                         Depends: imagemagick but it is not installable
    226. squeak-image3.9 : Depends: squeak-vm but it is not installable
    227. squid3-dbg : Depends: squid3 (= 3.3.8-1ubuntu6.2) but it is not going to be installed
    228. strongswan-plugin-unbound : Depends: libldns1 (>= 1.4.0) but it is not installable
    229. strongswan-tnc-base : Depends: libtspi1 (>= 0.3.1) but it is not installable
    230. subversion-dbg : Depends: subversion (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    231.                            libsvn1 (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    232.                            libapache2-mod-svn (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    233.                            subversion-tools (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    234.                            python-subversion (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    235.                            ruby-svn (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    236.                            libsvn-perl (= 1.8.8-1ubuntu3.1) but it is not going to be installed or
    237.                            libsvn-java (= 1.8.8-1ubuntu3.1) but it is not going to be installed
    238. sugar-etoys-activity : Depends: etoys but it is not going to be installed
    239.                         Recommends: sugar-session but it is not installable
    240.                         Recommends: sugar-presence-service-0.90 but it is not installable or
    241.                                     sugar-presence-service but it is not installable
    242. systemsettings : Depends: kde-runtime but it is not going to be installed
    243.                   Depends: libkcmutils4 (>= 4:4.4.95) but it is not going to be installed
    244.                   Depends: libkdecorations4abi1 (= 4:4.11.11-0ubuntu0.2) but it is not going to be installed
    245.                   Depends: libkdecore5 (>= 4:4.4.4-2~) but it is not going to be installed
    246.                   Depends: libkdeui5 (>= 4:4.6.3) but it is not going to be installed
    247.                   Depends: libkhtml5 (>= 4:4.3.4) but it is not going to be installed
    248.                   Depends: libkio5 (>= 4:4.4.0) but it is not going to be installed
    249.                   Depends: libknewstuff3-4 (>= 4:4.4.0) but it is not going to be installed
    250.                   Depends: libplasma3 (>= 4:4.4.95) but it is not going to be installed
    251. tegrarcm : Depends: libcrypto++9 but it is not installable
    252. tovidgui : Depends: python-tk but it is not installable
    253.             Depends: tovid (= 0.33-0ubuntu5) but it is not going to be installed
    254. ubuntu-emulator-images : Depends: ubuntu-emulator-runtime (= 20140328-2310-0ubuntu2) but it is not going to be installed
    255. uhexen2 : Depends: libmad0 (>= 0.15.1b-3) but it is not installable
    256.            Depends: libsdl1.2debian (>= 1.2.11) but it is not installable
    257. virtualbox-guest-dkms : Depends: dkms (>= 2.1.0.0) but it is not installable
    258. virtualbox-guest-source : Depends: build-essential but it is not installable
    259.                            Depends: debhelper (>= 5) but it is not installable
    260.                            Depends: kbuild but it is not installable
    261.                            Recommends: module-assistant but it is not installable
    262. vlc-dbg : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    263. vlc-plugin-fluidsynth : Depends: fluid-soundfont-gm but it is not installable or
    264.                                   musescore-soundfont-gm but it is not installable
    265.                          Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    266.                          Depends: libfluidsynth1 but it is not installable
    267.                          Depends: libvlccore7 (>= 2.0.0) but it is not going to be installed
    268. vlc-plugin-jack : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    269.                    Depends: libvlccore7 (>= 2.0.0) but it is not going to be installed
    270. vlc-plugin-notify : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    271.                      Depends: libvlccore7 (>= 2.0.0) but it is not going to be installed
    272. vlc-plugin-pulse : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    273.                     Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
    274. vlc-plugin-sdl : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    275.                   Depends: libsdl1.2debian (>= 1.2.11) but it is not installable
    276.                   Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
    277. vlc-plugin-svg : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    278.                   Depends: libvlccore7 (>= 2.0.0) but it is not going to be installed
    279. vlc-plugin-zvbi : Depends: vlc-nox (= 2.1.4-0ubuntu14.04.1) but it is not going to be installed
    280.                    Depends: libvlccore7 (>= 2.0.0) but it is not going to be installed
    281.                    Depends: libzvbi0 (>= 0.2.33) but it is not installable
    282. vmware-manager : Depends: libconfig-inifiles-perl but it is not installable
    283.                   Depends: libnumber-format-perl but it is not installable
    284.                   Depends: libterm-readkey-perl but it is not installable
    285.                   Depends: libtext-glob-perl but it is not installable
    286.                   Depends: libdata-dump-perl but it is not installable
    287. wnn7egg : Depends: emacs23 but it is not installable or
    288.                     emacs23-lucid but it is not installable or
    289.                     emacs23-nox but it is not installable or
    290.                     emacs-snapshot-gtk but it is not installable or
    291.                     emacs-snapshot but it is not installable or
    292.                     emacs-snapshot-nonx but it is not installable or
    293.                     xemacs21-mule but it is not installable or
    294.                     xemacs21-mule-canna-wnn but it is not installable or
    295.                     xemacs21-gnome-mule but it is not installable or
    296.                     xemacs21-gnome-mule-canna-wnn but it is not installable
    297. x-pgp-sig-el : Depends: emacsen but it is not installable
    298.                 Depends: pgp but it is not installable
    299. xaralx-svg : Depends: xaralx but it is not going to be installed
    300.               Depends: libwxbase2.8-0 (>= 2.8.12.1) but it is not installable
    301.               Depends: libwxgtk2.8-0 (>= 2.8.12.1) but it is not installable
    302. xserver-xorg-dev : Depends: libpixman-1-dev (>= 0.27.2) but it is not installable
    303.                     Depends: x11proto-core-dev (>= 7.0.22) but it is not installable
    304.                     Depends: x11proto-input-dev (>= 2.3) but it is not installable
    305.                     Depends: x11proto-xext-dev (>= 7.2.99.901) but it is not installable
    306.                     Depends: x11proto-video-dev but it is not installable
    307.                     Depends: x11proto-randr-dev (>= 1.4.0) but it is not installable
    308.                     Depends: x11proto-render-dev (>= 2:0.11) but it is not installable
    309.                     Depends: x11proto-dri2-dev (>= 2.8) but it is not installable
    310.                     Depends: x11proto-gl-dev (>= 1.4.17) but it is not installable
    311.                     Depends: x11proto-fonts-dev but it is not installable
    312.                     Depends: x11proto-xinerama-dev but it is not installable
    313.                     Depends: x11proto-kb-dev but it is not installable
    314.                     Depends: x11proto-xf86dri-dev but it is not installable
    315.                     Depends: x11proto-resource-dev (>= 1.2.0) but it is not installable
    316.                     Depends: x11proto-scrnsaver-dev but it is not installable
    317.                     Depends: x11proto-xf86bigfont-dev (>= 1.2.0) but it is not installable
    318.                     Depends: x11proto-dri3-dev but it is not installable
    319.                     Depends: x11proto-present-dev but it is not installable
    320.                     Depends: libxkbfile-dev but it is not installable
    321.                     Depends: libpciaccess-dev but it is not installable
    322.                     Depends: mesa-common-dev but it is not installable
    323.                     Depends: libmirclient-dev but it is not installable
    324. xserver-xorg-xmir : Depends: libmirclient7 (>= 0.1.8+14.04.20140411) but it is not installable
    325. xul-ext-lightning : Depends: thunderbird (= 1:31.3.0+build1-0ubuntu0.14.04.1) but 1:31.4.0+build1-0ubuntu0.14.04.1 is to be installed
    326.                      Recommends: xul-ext-calendar-timezones but it is not going to be installed
    327. yamagi-quake2 : Depends: libopenal1 (>= 1:1.13) but it is not installable
    328.                  Depends: libsdl2-2.0-0 (>= 2.0.0) but it is not installable
    329. zekr : Depends: default-jre but it is not installable or
    330.                  java5-runtime or
    331.                  java6-runtime or
    332.                  java7-runtime
    333.         Depends: libbasicplayer-java but it is not installable
    334.         Depends: libcommons-codec-java but it is not installable
    335.         Depends: libcommons-collections3-java but it is not installable
    336.         Depends: libcommons-configuration-java but it is not installable
    337.         Depends: libcommons-io-java but it is not installable
    338.         Depends: libcommons-lang-java but it is not installable
    339.         Depends: libcommons-logging-java but it is not installable
    340.         Depends: liblog4j1.2-java but it is not installable
    341.         Depends: liblucene2-java but it is not installable
    342.         Depends: libswt-gtk-3-java but it is not installable
    343.         Depends: libtritonus-java but it is not installable
    344.         Depends: velocity but it is not installable
    345.         Depends: libswt-cairo-gtk-3-jni but it is not installable
    346.         Depends: libswt-gnome-gtk-3-jni but it is not installable
    347.         Depends: libswt-webkit-gtk-3-jni but it is not installable or
    348.                  libswt-mozilla-gtk-3-jni but it is not installable
    349.         Depends: libjs-jquery but it is not installable
    350.         Depends: ttf-sil-scheherazade but it is not installable or
    351.                  ttf-kacst (>= 1.6.2+mry-1) or
    352.                  ttf-farsiweb but it is not installable
    353.         Recommends: libmp3spi-java but it is not installable
    354.         Recommends: libvorbisspi-java but it is not installable
    355.         Recommends: libjorbis-java but it is not installable
    356.         Recommends: libjspeex-java but it is not installable
    357.         Recommends: libjlayer-java but it is not installable
    358.         Recommends: islamic-menus but it is not installable
    359. E: Unable to correct problems, you have held broken packages.
    360. sa@ubuntu:~/Desktop/cpp$ g++ hello.c
    361. The program 'g++' is currently not installed. You can install it by typing:
    362. sudo apt-get install g++
    363. sa@ubuntu:~/Desktop/cpp$
    364.  
    after tried to install it gives this logs.
     
  2. Brownout

    Well-Known Member

    Jan 10, 2012
    2,375
    998
    It seems the solution is in your log:

    Code (Text):
    1. The program 'g++' is currently not installed. You can install it by typing:
    2. sudo apt-get install g++
     
Loading...