CP2102 Voltage Regulator Issue

Discussion in 'General Electronics Chat' started by Humbug44, Sep 10, 2016.

  1. Humbug44

    Thread Starter New Member

    Sep 10, 2016
    3
    0
    Hi Folks - my first post here.

    I have been using eBay CP2102's for some time with various projects. I recently bought 4 of these micro-usb converter boards - http://www.ebay.com.au/itm/191736125396?_trksid=p2057872.m2749.l2649&ssPageName=STRK:MEBIDX:IT. When I checked the '3.3V' output on these boards, they all measured voltages around 4 or 4.2 volts. I bought two from two different suppliers so I don't know if they were the same batch or not.

    I've checked the circuit boards as best I can, and they do appear correct and set up for a bus power supply. I've also check that they have been programmed for a bus power supply in the CP2102 internal register - and again, all appears in order.

    I'm at a loss now. If it were a bad batch of chips, I would have expected to see others with the same problem on the internet - but nothing. If anyone has had a similar experience or can throw some light on this, I would be very grateful!

    Regards
    Mike H
     
  2. Hypatia's Protege

    Distinguished Member

    Mar 1, 2015
    2,803
    1,237
    Many regulator schemes require a minimum load -- Have you observed the output EMF under nominal load?

    Best regards and good luck!
    HP:)
     
  3. Humbug44

    Thread Starter New Member

    Sep 10, 2016
    3
    0
    Thanks for for your reply HP. Yes I did check it with a 20 mA load but the voltage only came down to about 4.05V. Given the rated output of the reg is only 100mA, this should have pulled it down to 3.3V I think.

    Mike H
     
  4. Hypatia's Protege

    Distinguished Member

    Mar 1, 2015
    2,803
    1,237
  5. Hypatia's Protege

    Distinguished Member

    Mar 1, 2015
    2,803
    1,237
    I agree:( Can you get a look at Vdd on a TDO?
     
  6. Humbug44

    Thread Starter New Member

    Sep 10, 2016
    3
    0
    I've just probed all the pins on the chip directly. Everything appears to be in order except for Vdd which was ~ 4V with a 40 mA load.
     
Loading...