Can't ID this device

Discussion in 'General Electronics Chat' started by Gdrumm, Sep 23, 2011.

  1. Gdrumm

    Thread Starter Distinguished Member

    Aug 29, 2008
    684
    36
    I am trying to use a Plextor ConvertX PX M402 U video editing / manipulating device, and it won't power up.

    I get power to the board, and I can measure power at various components (caps), but the LED doesn't come on.

    The picture show a device I can't recognize. It looks like a small button battery encased in epoxy? The numbers on top say 680 L41.

    Can anyone tell by looking at the pictures what it might be, and what it does?

    Thanks,
    Gary
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,649
    2,348
    Hello,

    The device is probably a choke (coil).
    It must have some low ohm value reading between the connections.

    Bertus
     
  3. BMorse

    Senior Member

    Sep 26, 2009
    2,675
    234
    As Bertus said, or it is an Inductor as L is used most of the time to indicate an inductor coil..... 680 is most likely the value in uH.... L41 is most likely the component number for the mfg.....
     
    Last edited: Sep 23, 2011
  4. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    8,754
    760
    Is it too much to post a focused picture ?
     
  5. Gdrumm

    Thread Starter Distinguished Member

    Aug 29, 2008
    684
    36
    I'm sorry the pictures had some glare, and seemed out of focus.

    I'll work on that..

    Thanks,
    Gary
     
  6. colinb

    Active Member

    Jun 15, 2011
    351
    35
    Does your camera have a “macro” mode (often represented on compact digicams with an icon of a flower)?
     
  7. oldtech33709

    New Member

    Sep 24, 2011
    26
    0
    It looks like an inductor, its in the power circiut based on the parts around it. Maybe part of a buck converter, 5V to 3.3V?
     
Loading...