BLDC motor spice model for LTSpice

Discussion in 'General Electronics Chat' started by grieche81, Jan 20, 2015.

  1. grieche81

    Thread Starter New Member

    Sep 2, 2011
    10
    0
    Hallo forum fellows,

    I would like to familiarise myself with the BLDC Motor Drive and its control that is why I want to run the first example MotorTest01.asc "Brushless DC Motor Model Test with Trapezoidal PWM Drive". In spite of following the installation tips that are given in the Word Document "BLDC 3-Phase Motor.doc", I receive the error message " Could not open library file "C:\Program Files\LTC\SwCADIII\lib\cmp\standard.dio" " and I cannot find a way to solve this problem.
    I have tried the following:
    Supposing that the encrypted BLDCSupport.lib has the needed information e.g. about LIMIT,ABS,GAIN, INT, SUM2, SUM3 usw, then in BLDC.lib, I have written the complete path for BLDCSupport.lib,
    * --------------------------------------------------------------------------------- *
    .lib C:\Program Files (x86)\LTC\LTspiceIV\lib\sub\BLDCSupport.LIB
    .lib SK_Friction.MOD
    * --------------------------------------------------------------------------------- *
    but it gave back the same message as above.

    Could you propose a solution?

    Thanks a lot in advance!!!
    Please follow this link: http://ltwiki.org/files/LTspiceIV/examples/Motors/
     
  2. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,762
    1,099
    Isn't that telling you your LTspice software is missing the usual standard.dio library? Maybe a re-install is needed?
     
  3. grieche81

    Thread Starter New Member

    Sep 2, 2011
    10
    0
    Hi Alec!
    This happens only in the case that I try to implement this example...the other examples I have not tried them yet. When I create another schematic and simulate it that has nothing to do with the example or its components, then LTspice works fine!
    Also I would like to mention that the path in my pc is:

    C:\Program Files (x86)\LTC\LTspiceIV\lib\cmp

    I cannot understand where the other path is defined. Could you think of any other reason?
     
  4. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,762
    1,099
    Presumably within the encrypted file.
    Perhaps try copying the standard.dio file to a new folder C:\Program Files\LTC\SwCADIII\lib\cmp\?
     
    grieche81 likes this.
  5. ericgibbs

    Senior Member

    Jan 29, 2010
    2,499
    380
    hi,
    Please post the full Folder Path, within the Program Files folder on your Hard drive.
    Mine paths are:
    C:\Program Files\LTC\LTspiceIV
    C:\Program Files\LTC\LTspiceIV\lib
    C:\Program Files\LTC\LTspiceIV\lib\sub

    E
     
  6. eetech00

    Active Member

    Jun 8, 2013
    644
    110
    This suggestion works, but you have to create the whole folder path if it doesn't already exist.
     
  7. eetech00

    Active Member

    Jun 8, 2013
    644
    110
    Hi

    The folder path is hard coded in the encrypted library file.

    Create a folder to store the schematic and all the support files.
    Then follow Alex_T suggestion in post #4.

    eT
     
  8. grieche81

    Thread Starter New Member

    Sep 2, 2011
    10
    0
    Alec_t, I have created the new folder to the above mentioned path, I copied the required files and now works just fine!!!

    Thanks all of you for your time! Have a nice day or night!!!
     
  9. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,762
    1,099
    Good to know it now works. Shame the author of the encrypted file made things awkward for other users.
     
Loading...