BA1404 FM Transmitter- not working so far

Discussion in 'General Electronics Chat' started by takao21203, Oct 24, 2014.

  1. takao21203

    Thread Starter Distinguished Member

    Apr 28, 2012
    3,577
    463
    I have built a small BA1404 circuit
    http://electronics-diy.com/BA1404_Stereo_FM_Transmitter.php

    Some parts were changed:

    33K instead of 27K
    3.9k instead of 5.6
    56K instead of 47K

    15ppF instead of 10pF
    8 T coil instead of 3 1/2 T

    It is not transmitting actually.

    I want to try a 5 or 6 pF capacitor (in parallel to the coil), perhaps the frequency is off.

    Also I dont have a 38 KHz crystal, used 32 KHz instead. Could this result in no signal arriving at all? What happens if the Stereo carrier is just 32 KHz?

    No signal, or just not stereo? I could wire up a small controller to generate 38 KHz but I think I should get some signal with 32 KHz too.

    I've connected a 3.5mm adapter cable to my netbook on the audio inputs, and I use a small battery powered radio. Tried yesterday but no signal at all, I guess using 15pF and a 8T coil, the frequency is too low.
     
  2. takao21203

    Thread Starter Distinguished Member

    Apr 28, 2012
    3,577
    463
    The capacitors also are just 4.7uF ceramic (i have read at low voltages they can have lower capacity)?

    But this shouldnt be the reason for no signal at all.
     
  3. alfacliff

    Well-Known Member

    Dec 13, 2013
    2,449
    428
    usiong both higher capacitance and more turns will put your transmitter way below the fm broadcast band. are you sure it is not transmitting, or are you just looking from 88 to 108 mhz? the 38 khz crystal is for the stereo subcarrier, if you use 32 khz, no standard fm radio in the woreld will hear it.
     
  4. takao21203

    Thread Starter Distinguished Member

    Apr 28, 2012
    3,577
    463
    I am not receiving, lets put it that way.

    Wouldnt the radio fallback to mono if it cant detect the 38 KHz carrier? What is the margin, and why?
     
  5. takao21203

    Thread Starter Distinguished Member

    Apr 28, 2012
    3,577
    463
    Changed to 5 pF today, I am getting transmission now, but range is short and quality is pretty bad.

    Also when I turn up the volume, there is no effect at some point it even goes off.
    Problem with the Stereo separation- 32 KHz isnt good. Have to wait for 38 KHz crystals.

    When I connect the antenna to the IC side end of the 150K resistor I get a much better transmission.
     
  6. BR-549

    Well-Known Member

    Sep 22, 2013
    1,981
    388
    Did you built the designed circuit first? This will give you a quality and range reference to go by.
    What aspect of the transmitter were you trying to modify?
     
  7. takao21203

    Thread Starter Distinguished Member

    Apr 28, 2012
    3,577
    463
    I built the circuit linked in the schematic. Nothing was modified except component values, some just minor, also 4.7uF instead of 10uF.

    I think 38 KHz crystal is required, since the volume adjustment at the receiver isnt working right.

    Also there should be 1nF capacitors at the inputs to GND, as seen in the datasheet.

    Guess I have to wait for the crystals.
     
Loading...