Audio/Video receiver Issue

Discussion in 'General Electronics Chat' started by mbxs3, Sep 19, 2011.

  1. mbxs3

    Thread Starter Active Member

    Oct 14, 2009
    Hey guys,

    I have a Denon AVR-686 A/V receiver that I am having power issues with. When I turn it on, it will start up and remain on for 5-10 seconds and turn off. If I keep cycling the on off switch, eventually it will remain on. I can hear a relay click when it switches off, and a red light around the power switch blinks repeatedly.

    It is a 120 VAC, 60 Hz device. I will open her up and take some pics of the innards by the end of the day. And maybe try and get a video of the power up sequence for ya'll to see.

    Any suggestions on what actions to take to repair?
  2. colinb

    Active Member

    Jun 15, 2011
    It sounds like it has a “soft” power switch in which some circuitry takes the logic input from the power button and decides how to control the relay switching on and off the main power supply.

    Maybe the power supply is running out of spec (failed electrolytic cap?) and there is a power supervisor that switches off the power when normal conditions are violated. The blinking red light after it shuts off makes me think it has detected a problem of some sort: undervoltage, overvoltage, etc.

    I would try to find the power supply rails and measure the voltage to see if they are stable.
  3. mbxs3

    Thread Starter Active Member

    Oct 14, 2009
    Here is a pic of the power section of the board. It seems to be about 5.5 seconds that the unit will stay on before it switches off.

    Here is a link to a quick video of what is going on.
    Last edited: Sep 20, 2011