Audio Amp Hybrid, help

Discussion in 'The Projects Forum' started by CRY&PRAY, Sep 24, 2014.

  1. CRY&PRAY

    Thread Starter Member

    Jan 6, 2014
    84
    0
    Hello guys :), Here is the progect that I'm doing:

    I'm trying to build a hybrid amp between a crappy 400 watt RMS Pyle Pro PTA1000 and the remainings of a Omnitronic E900. What i've done till now is to use the heatsink of the Omnitronic and mount 8 Transistor (2sc5200 and his bro) with their 0,5 Ohm resistor and all that things. Wired the bases and the Emitters to the Pyle Pro boards (that uses the same drivers transistors "2sa1837" and "2sc4793" as the burned Omnitronic Amp cirquit). So now i have a bank of transistor hooked up to the Pyle Pro, Amplifing as normal, and biased correclty with a multimeter moving the 2 "a lots of turns" pot on the board. here is the problem, the Pyle Pro Toroidal is 47.5 VDC +-, the Omnitronic one is 90 VDC +-. I'm sure that all the final can handle that power because they were in the Omnitronic amp, but will the Pyle Pro boards? can I ground both toroidal and use the 45 VDC for the boards and separate all the collectors of the Finals and hook them up to the Omnitronic transformer? Will i blow something doing that? (i'm building this hybrid because I've tried to repair the Omnitronic board too many times, each time a different problem...)

    Thx, Francesco.

    Sorry for the long post but english is not my native language :)
     
  2. CRY&PRAY

    Thread Starter Member

    Jan 6, 2014
    84
    0
    no one? :(
     
  3. CRY&PRAY

    Thread Starter Member

    Jan 6, 2014
    84
    0
    Well i was a bit scared but luckily it worked, now i have to move all the preamp part from the Pyle to the Other one and fit all the things in a 2U box with half already occupied by the big toroidal... I'll post some photo of the Hybrid when done :)
     
    Last edited: Sep 25, 2014
Loading...