astrophysics 100xd x-ray machine

Discussion in 'General Electronics Chat' started by airbustel, Mar 15, 2011.

  1. airbustel

    Thread Starter New Member

    Feb 23, 2011
    3
    0
    Hello everyone,

    Just wanna ask if anyone could help me find a service manual for astrophysics 100XD x-ray machine.
    Basically I have been given a task by my boss to test a mobile x-ray machine which i did it for a very first time. When I power up the system, everything works fine as I've seen it rollers moving back & forth when I press the forward and reverse button. But when I put an object inside the x-ray machine, there is no image came out on the screen monitor. It shows only vertical lines just like a bar coded lines instead of the usual image of the thing that i put inside.

    Is there any lens on the x-ray machine that needs to be clean? What other possible causes of this problem?

    Appreciate any idea or help that you may extend.


    Thank you very much in advance.

    airbustel
     
  2. jpanhalt

    AAC Fanatic!

    Jan 18, 2008
    5,684
    900
    You need to call a trained X-ray service tech.
    John
     
  3. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    The company website is here:
    http://www.astrophysicsinc.com/
    Telephone numbers and a technical support page link are provided.

    Please don't attempt to disassemble the machine, as the X-ray tube is driven with 180kv.
     
    PackratKing likes this.
  4. airbustel

    Thread Starter New Member

    Feb 23, 2011
    3
    0
    Thanks SgtWookie & jpanhalt for your reply.

    I have found the problem by removing the x-ray generator then trace the v.24 interface cable connected to the PC leading to the series of cards that provides the gamma rays. some of the connectors were detached which causes image not clearly displayed on the system monitor.

    Once again, thank you very much for your time and info provided.


    Airbustel
     
Loading...