.ASC Files

Discussion in 'Feedback and Suggestions' started by ronv, Jul 23, 2014.

  1. ronv

    Thread Starter AAC Fanatic!

    Nov 12, 2008
    3,292
    1,255
    We were trying to post some spice files (.asc), but it appears that somehow they get converted to .php files. Needless to say paint can't open them and neither can LtSpice open the .phps. Did I do something wrong or is it a buglet?
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,348
    Hello,

    Did you try an other browser?
    I had a similar problem and switched to an other browser.

    I also have asked jrap to have a look at it.

    Bertus
     
  3. jrap

    Administrator

    Jun 25, 2006
    961
    200
    Hi Ronv - what browser are you using? That will help us debug the issue. .ASC files seem to download fine with the latest Chrome that I'm using.
     
  4. tshuck

    Well-Known Member

    Oct 18, 2012
    3,531
    675
    There is a PHP file that is responsible for fetching the attachment/resource... Is this what you are referring to?

    Was the vBulletin software updated at all? They may have changed how files are served...
     
  5. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,804
    1,105
    In Firefox, left-clicking the .asc link works fine. It gives a pop-up box with an option to save the file or run it with LTS. What is annoying, though, is that .asy files used in LTS aren't accepted for upload (without the hassle of changing their extension or zipping them). Perhaps jrap could fix that? Pretty please :).
     
    Last edited: Jul 24, 2014
  6. jrap

    Administrator

    Jun 25, 2006
    961
    200
    tshuck - No updates to vB lately!

    For sure Alec - It's added now. I've also updated both file's mime-types to "text/plain" to see if that fixes the download issue.
     
    Alec_t likes this.
  7. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,804
    1,105
    Thanks for the .asy fix, jrap. That was quick!
     
  8. ronv

    Thread Starter AAC Fanatic!

    Nov 12, 2008
    3,292
    1,255
  9. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,348
    ronv likes this.
  10. jrap

    Administrator

    Jun 25, 2006
    961
    200
    This is a solution I found from another board running vBulletin:

    Go to:
    Menu > Tools > Compatability View settings (or click the Tools icon to get there). Add AAC to the Compatibility View list
     
    ronv likes this.
  11. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,348
    Hello,

    In firefox, you can tell the browser what to do with the files:

    [​IMG]

    Bertus
     
  12. ronv

    Thread Starter AAC Fanatic!

    Nov 12, 2008
    3,292
    1,255
    Compatibility mode fixed it. Don't know why, but I'm happy anyway.:D

    Thanks
     
Loading...