ADC error

Discussion in 'General Electronics Chat' started by Hochberger, Apr 16, 2011.

  1. Hochberger

    Thread Starter New Member

    Mar 15, 2011
    Hi all.
    I have a problem with my ADC converter. I think that it may be burned (my silly mistake) but not really sure. I´m passing data to ADC according to datasheet. SCK, CS and DIn ... I checked it hundred times, everything fine. But DOut is providing only noise but sometimes it provides me the right data. And I don´t know if the chip is really burnt ...

    So my question: Is it possible that the chip is partially burned and providing right data only sometimes?

  2. debjit625

    Well-Known Member

    Apr 17, 2010
    Give details about your ADC chip i.e.. which ADC chip you are using and how you are testing the device,hardware?
  3. Hochberger

    Thread Starter New Member

    Mar 15, 2011
    So, I´m using MCP3208 ADC. I made a circuit involving 4 PIR photodiodes with 5V bias. I´m reading diodes generated voltage in single-ended mode. There is not a problem in my scheme or code. It worked fine but I possibly burned the ADC ... I´m not asking whether my scheme is right ... I just know it is ...

    I have the only question: Is it possible that ADC is only partially burned??? It provides mainly the noise but sometimes it provides output data but just for a few seconds ... than again noise.

    I know that there could be just a bad contact somewhere but it means to unsolder whole ADC [​IMG] and test it on my second microprocessor. For me it is whole day work and I don´t have this time.

    So thanks again for each reply!!!
  4. Ron H

    AAC Fanatic!

    Apr 14, 2005
    I've heard that before.:rolleyes:
    Without a schematic, we can't be of much help.