7 seg display issue

Discussion in 'General Electronics Chat' started by Nathan Hale, Nov 21, 2013.

  1. Nathan Hale

    Thread Starter Active Member

    Oct 28, 2011
    125
    2
    Hello guys! I have a 7 seg display issue. I am trying to light up a 7 seg display. the IC i am using is made to drive common anode 7 seg displays, and the 7 seg display i have in my home is a common cathode.
    Any ideas how i can still get the 7 seg display to light up???

    Thank you for your replies.
     
  2. shteii01

    AAC Fanatic!

    Feb 19, 2010
    3,387
    497
    You could put inverter between the driver chip and the 7 seg. display. Basically it is IC with a NOT gate. When you apply 0 to the gate, 1 comes out. When you apply 1 (or whatever voltage correspond to 1), 0 comes out.

    If I remember right, in logic lab we used such IC that had either 4 or 6 NOT gates. Each display has 7 LED, so you need 7 NOT gates.
     
    Nathan Hale likes this.
  3. MrChips

    Moderator

    Oct 2, 2009
    12,440
    3,361
    Use the CD4511 decoder/driver instead of the 7447.
     
  4. shteii01

    AAC Fanatic!

    Feb 19, 2010
    3,387
    497
    This, pretty much. If you gonna order parts, anyway, might as well order one chip.
     
  5. MrChips

    Moderator

    Oct 2, 2009
    12,440
    3,361
    So you have to order more parts.

    You have to decide.

    Order some CD4511 to go with your common cathode displays

    OR

    order some common anode displays to go with your SN7447

    OR

    order parts for both cases and then you wouldn't be stuck without parts in future.
     
    Nathan Hale likes this.
  6. Nathan Hale

    Thread Starter Active Member

    Oct 28, 2011
    125
    2

    It worked guys!!!! My first digital project and it works!! it counts down from 3 till 0!!
    I was stuck with a ic that would work with a common anode 7 seg display but as shteii01 said i took all the out puts from the 7447 ic and inverted them using 2 7404 inverters and bang !!! it is working!!! thank heavens!!! i am so excited!!!!3 days of HARD work and brain racking finally paid off!!

    p.s. just that you know the display would not display the numbers right at first. i thought it was a bad IC . no, the ic was good its just that i was misguided by some website which gave the pin configuration as abXcd and efXg(dp) instead of gfXab and edx(dp)

    Thank you all!!!!!!!!
     
  7. shteii01

    AAC Fanatic!

    Feb 19, 2010
    3,387
    497
    You are welcome.
     
Loading...