555 Beginner Issues - Help

Discussion in 'The Projects Forum' started by usdiggs, Dec 12, 2006.

  1. usdiggs

    Thread Starter New Member

    Dec 4, 2006
    8
    0
    I am trying to make a countdown timer (it only needs to be for 2 minutes) and am having a lot of problem with the 555 timer. Can anyone help me please??? I would really appreciate knowing where I have gone wrong. Counting up on the 7 segment displays works by pressing a button, but the 555 timer is to pulse the down counter.

    Thanks
     
  2. pebe

    AAC Fanatic!

    Oct 11, 2004
    628
    3
    It may be that you are losing the pulse trying to take the output through a 7805 regulator. Why do that? Why not run the 555 from the 5v regulated line and feed the 74*** direct?
     
  3. JoeJester

    AAC Fanatic!

    Apr 26, 2005
    3,373
    1,158
    usdiggs,

    I was wondering why you choose to feed the output of the top LM7805 straight to ground via the UP switch?

    I never seen a regulator used in that fashion before (your second LM7805).

    Have you clicked on the help for the operating point not found?

    Anyways, I've redrawn your circuit and attached the file. In the future you might want to clean up your drawings for the ease of troubleshooting.
     
  4. usdiggs

    Thread Starter New Member

    Dec 4, 2006
    8
    0
    Thanks JoeJester & Pebe. I had the second LM7805C there because I was getting just over 7 volts out and was told the chips should be run on 5V.

    Thanks for you re-draw JoeJester, it does make it a lot easier to read.
     
  5. JoeJester

    AAC Fanatic!

    Apr 26, 2005
    3,373
    1,158
    The redraw was to help you troubleshoot the problem.

    I haven't looked at it closely yet, but I will later tonight. Maybe by the time I get back from my tax class, you'll have it all repaired and will tell us what you did.

    Have a good time.
     
Loading...