All About Circuits Forum  

Go Back   All About Circuits Forum > Electronics Forums > Homework Help

Notices

Homework Help Stuck on a textbook question or coursework? Cramming for a test and need help understanding something? Post your questions and attempts here and let others help.

Reply   Post New Thread
 
Thread Tools Display Modes
  #1  
Old 08-25-2011, 08:02 AM
keithisdoped keithisdoped is offline
Junior Member
 
Join Date: Aug 2011
Posts: 14
Default LED Dice using 555 and 4017 problem

hi as shown in my schematics , it doesn't simulate as how it should in multisim.. i have done the project and even build it out and it is working, but in multisim only the rolling effects of the dice is seen but after that the leds turn off.. this schematic was given by my friends university (NTU) ... any idea why? thanks for your time geniuses
Attached Images
File Type: png Untitled.png (28.9 KB, 38 views)
Reply With Quote
  #2  
Old 08-25-2011, 12:19 PM
praondevou's Avatar
praondevou praondevou is offline
Senior Member
 
Join Date: Jul 2011
Location: Canada
Posts: 2,887
Default

If had some problems with Multisim counters (not this one in particular though)

Connect the CON pin of the 555 via a 10nF capacitor to ground.

Check with an oscilloscope if the CARRY_OUT , pin12, is working properly. refer to the datasheet timing diagrams.http://www.national.com/ds/CD/CD4017BC.pdf

Also , are the wires at the anode of LED2 properly connected? (you can pull LED2 down a bit to see this)

Also the 4017 you use is the 5V version, but I don't think it matters.
Reply With Quote
  #3  
Old 08-25-2011, 02:59 PM
keithisdoped keithisdoped is offline
Junior Member
 
Join Date: Aug 2011
Posts: 14
Default

Quote:
Originally Posted by praondevou View Post
If had some problems with Multisim counters (not this one in particular though)

Connect the CON pin of the 555 via a 10nF capacitor to ground.

Check with an oscilloscope if the CARRY_OUT , pin12, is working properly. refer to the datasheet timing diagrams.http://www.national.com/ds/CD/CD4017BC.pdf

Also , are the wires at the anode of LED2 properly connected? (you can pull LED2 down a bit to see this)

Also the 4017 you use is the 5V version, but I don't think it matters.

yeap i'm using the 5v version, and i've checked using the oscilloscope, the outputs are right but the light doesn't stay on like how it is on my prototype.
this is weird D:
Reply With Quote
  #4  
Old 08-25-2011, 03:59 PM
keithisdoped keithisdoped is offline
Junior Member
 
Join Date: Aug 2011
Posts: 14
Default

seems like this schematics from http://www.kpsec.freeuk.com/projects/dice.html also has the same problem.. it's almost similar to the one i have.. so what's wrong -.- must be multisim i guess?
Reply With Quote
Reply   Post New Thread

Tags
, , , ,


Related Site Pages
Section Title
Textbook LED sequencer : Digital Integrated Circuits


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help regarding 555 timers and 4017 counter JingleJoe The Projects Forum 15 07-27-2011 09:58 PM
Triggering a One-Shot 555 with a 4017 DanRilley General Electronics Chat 13 04-18-2011 04:21 AM
LED Sequencer 110416 allenpitts The Projects Forum 4 04-18-2011 01:27 AM
555 and 4017 timer circuit. One or two 555's? Len Whistler General Electronics Chat 5 12-11-2010 12:43 PM
555 4017 led simulation using yenka program customsportbike The Projects Forum 2 02-14-2010 11:35 PM

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:44 PM.


User-posted content, unless source quoted, is licensed under a Creative Commons Public Domain License.
Powered by vBulletin
Copyright ©2000 - 2014, vBulletin Solutions, Inc.