All About Circuits Forum

All About Circuits Forum (http://forum.allaboutcircuits.com/index.php)
-   The Projects Forum (http://forum.allaboutcircuits.com/forumdisplay.php?f=6)
-   -   Half bridge inverter (http://forum.allaboutcircuits.com/showthread.php?t=11632)

Marie 05-14-2008 07:41 PM

Half bridge inverter
 
1 Attachment(s)
Hi,

I'm trying to build a filter to eliminate harmonics generated by non linear loads. The operation is quite simple. It uses a force commutated inverter to inject negative harmonics current into the power line.

The inverter consists of three half bridge operating on a per phase basis. I've attached a diagram for a better understanding.

Here is what is done:
1) I sense the load current,
2) extract harmonics content,
3) invert it, the signal is used as reference for the control system
4) generate gating signals for switches of the inverter.
5) inject harmonic current

The inverter is a voltage source inverter which uses a dc supply and a dc link capacitor split at midpoint.

The control circuit works out fine. Problem arises with the inverter. It seems that the capacitor tends to discharge into the dc supply. Now the supply can only accept unidirectional current; u can imagine the reaction; both current and voltage behaves 'strangely'.

As a remedy, I've tried to use a small resistance (100ohm) in series with the capacitors. It works when i used a dc input of 15V. But at 75V (the required dc for the system), it does not work.

I must mention that up to now, I've only tested only a half bridge and not the whole system.

The fact is that as long as i'm unable to maintain a stable dc voltage, i cannot obtain any reliable harmonics current to inject.

Could anyone suggest a solution to this problem? I've tried using diode but it had no effect.

Hope it does not sound too confusing.

Thank you

thingmaker3 05-15-2008 01:24 PM

Have you tried diodes between the supply and the caps?

Marie 05-15-2008 06:15 PM

Hi,

Yes I did try using diodes but it didn't change anything. What baffles me is that with 15V I am able to maintain constant supply using the 100ohm resistance while with 75V (three power supply in series) it does not work? Shouldn't the internal resistance of battery be larger at 75V?

By the way, the capacitor value is 220uF each.


All times are GMT. The time now is 01:04 PM.

Powered by vBulletin
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2003-2014, All About Circuits. All Rights Reserved.